Monday, February 12, 2007

Blogger Woes

Does anyone know where my sidebars have gone? A few months ago, they simply ran away from home without provocation. Disappeared without leaving a note. One day they were there, the next day they were gone. And I had not been mucking about in the template. I kept hoping they'd come back, as the blog just doesn't look right without them, and I do like the functions they perform. I discovered that clicking on the timestamp for any given post will bring up that post and its comments as a single page, and the sidebars are intact there, except for the archives. There are no archives at all. I have gone back through the template and everything is there as it should be. So what's wrong?

When I look at the blog in Firefox instead of Internet Explorer, the sidebars are intact, including the archives. But the main page comes up showing the most recent post as over a month ago. If I type in the exact URL of the most recent post, that page will come up; but the main page is never current.

When I made the switch to Blogger Beta about two weeks ago, I hoped this problem would be corrected, but it was not. Any suggestions?

Labels:

10 Comments:

Blogger Flea said...

I see them! IE 7.0

Flea

Monday, February 12, 2007 9:44:00 AM  
Anonymous kuskomama said...

I see all the sidebars, the most recent posts are the correct ones, your monthly archives, and then your blog-roll. Looks normal to me. I'm using IE 7.0. Maybe delete all your temp files and cookies and refresh? I'm sorry you're having issues!

Monday, February 12, 2007 11:40:00 AM  
Blogger schneidler said...

Hi. I can see the sidebar, but I always use firefox. And it always shows the most recent post when I load it (as far as I know), no problem. I'm sorry I'm not a blogger and can't give you any insight as to its quirks. I just wanted you to know I have none of those problems as an outside viewer of your site.
-peter in Kasigluk

Monday, February 12, 2007 2:07:00 PM  
Blogger #1 Dinosaur said...

I read your blog in Firefox, and it's all there; sidebars, current posts and all.

Try this: call it up in Firefox. If your most recent post(s) aren't there, try clicking your "refresh" button. That usually helps me when new posts don't show up at first.

Word Verification: "purciki" = how picky Blogger can be

Monday, February 12, 2007 3:02:00 PM  
Anonymous Anonymous said...

It looks fine to me in both Firefox and IE (the latest version). I don't have the older IE installed anymore so can't check that.

It could be just you who isn't getting the sidebars and updated main page. Have you tried completely clearing your cache and browser history and then reloading the page?

Styleygeek (who can't be bothered logging in)

Monday, February 12, 2007 3:26:00 PM  
Anonymous Laura said...

I'm not positive what your "sidebars" are, but I am thinking that they are the previous posts, archives, about me, legal disclaimer, etc. If I am correct, they have never disappeared for me. I use Internet Explorer.

I don't know why you wouldn't be able to view them...that's strange...maybe it's global warming...

:o) Sorry I couldn't be more help!

Laura, Alabama based Alaska addict!

Monday, February 12, 2007 5:59:00 PM  
Blogger TheTundraPA said...

Groan! The perils of being a late adaptor, I guess. Somehow I had just never gotten around to updating either IE or Firefox. Now I have, and voila! Everything is back to normal. I shouldn't have waited so long. Thanks for the advise!

Monday, February 12, 2007 9:59:00 PM  
Blogger SusanE said...

I see them, but one thing i've noticed. When people use large pictures that can sometimes cause the sidebar to drop down to the bottom of the page, especially it seems if the pictures are either left or right (rather than centred)

Tuesday, February 13, 2007 5:03:00 AM  
Blogger Bardiac said...

For me, your sidebars have all gone to the bottom of the page.

It happened to me once, and someone said it had to do with the width of one of the way the columns were set up, and that changing that width by 1 in the template would change it.

I don't remember the exact fix they suggested, but it worked; I'll try to find it for you.

Thursday, February 15, 2007 5:34:00 AM  
Blogger Bardiac said...

Here's the suggestion Sharon made when I had the problem; I haven't looked at your template, but following her directions solved the problem for me.

Pasting:
When that happens, it's usually because your two columns are fractionally too wide to float alongside each other on the screen as they should. (And when I say fractionally, I mean often by as little as 0.1% or a single pixel.) Maybe it's just that one of the new additions to the blogroll takes up exactly the whole width of the sidebar. Some browsers are worse about this than others, which is why some people won't see the problem. (It's no accident that several people reporting the problem are using Internet Explorer... Get yourself Firefox or Opera, folks!)

So, I've looked at your template and there's a bit that goes like this:

#content {
width:660px;
margin:0 auto;
padding:0;
text-align:left;
}
#main {
width:410px;
float:left;
}
#sidebar {
width:220px;
float:right;
}

If you take 1 or maybe 2 pixels off the sidebar width (ie, reduce it from 220 to 219 or 218), you should avoid the problem in future.

/end paste

I hope that helps!

Thursday, February 15, 2007 5:46:00 AM  

Post a Comment

Links to this post:

Create a Link

<< Home